SQLTeam.com | Weblogs | Forums

Upgrade from SQL2008R2 to SQL2016 broke SSRS


#1

I did an in place upgrade from SQL2008R2 SP3 to SQL2016. Everything went fine with the upgrade, however SSRS isn't working. It starts fine (SSRS service running) however I can't access the reports page. When going to SSRS Config. Manager, the "Report Server Instance" box is empty and greyed out (can't key into it). When clicking Find, I get a message that there are no report servers found. I tried changing the compatibility level of ReportServer and ReportServerTemp to 130 (it was left at 100 after the upgrade). This didn't help. I've rebooted the server a couple times. Still no luck. Does anyone have any ideas?

Thanks,

Van


#2

have you checked event logs? these will usually yield the underlying cause of this issue.
Is Reporting Service running?
What state are the databases?
did the upgrade require restart? if so are all required services running?


#3

Did you export the encryption key prior to the upgrade? And - did you apply the saved encryption key after the upgrade?


#4

Thanks for the replies. I got it taken care of. I wanted to follow up with what the issue was. Security is pretty tight at our company. We use CyberArk to rdp to servers. After 10 min if inactivity, it disconnects you. When doing this upgrade from SQL2008R2 to SQL2016, I stepped away for a few minutes and got disconnected (or so I thought). Actually what happened was that CyberArk logged me off (not just a disconnect) in the middle of the upgrade. I did a repair on the SQL2016 upgrade and it resolved the issue. I will be speaking to our security dept. about this. It should have just disconnected me and not logged me off.

Thanks again,

Van