SQLTeam.com | Weblogs | Forums

Uninitialized subscription

Hi SQL Team Members,

Would like to ask if anyone from you here encountered this certain error in SQL transactional replication. Upon checking with the replication monitor, noticed that there is an error with the subscription "UNINITIALIZED SUBSCRIPTIOn" and found out that the Distributor to Subscriber is not working well. In fact, when I run the "Insert Tracer" for the latency check, the status on Publisher to Distributor is 01, while for Distributor to Subscriber is still "Pending" which is quite weird because I have setup another publications on the same server which is working well.

See Below image.
uninitialized subscription

Still this error was not yer resolved.

This problem has been resolved. I just removed the subscription which was created via script and then manually created subscription via GUI in the subscriber instance. Reinitialized the subscription and then it went ok. Still clueless on what is the root cause of this error.

hi

welcome !!!

why it worked DONT KNOW !!
Still clueless on what is the root cause of this error.

has happened to me a MILLION times ...
As long as it works !!! :wink:

unless how it worked is IMPORTANT !!