SQLTeam.com | Weblogs | Forums

Unable to execute ssis 2012 package from BIDS


#1

Hi,

When i tried to execute package from BIDS, facing below error

"Failed to execute the package or element, Build errors were encountered. For more information, see the output window."

i tried to build the solution but its failed showing below error.

"System.IO.IOException: The process cannot access the file 'E:-------\bin\Development\SSIS.ispac' because it is being used by another process."

But no one has opened the solution other than me, i stuck here and not able to execute package.
How to resolve this?


#2

Hi,

Pls try this method.

You have probably already restarted SSDT, but that didn't help. Open the Task Manager (Ctrl + Shift + Esc) and locate DtsDebugHost.exe under Processes and end that process (could be multiple times, end them all). Now try running the package again.

This happens when SSDT/Visual Studio crashes during runtime. If you kill SSDT then the SSIS Debug Host will still be active locking the ISPAC file.


#3

Thank You Jai for your quick response.
It got resolved and able to run package from BIDS