SQLTeam.com | Weblogs | Forums

Unable to execute mysql commands from terminal

mysql

#1

I have just completed a new mySQL install on my Mac. The new install appears to be working properly. I can turn SQL on and off. I can create a database and make tables. I want to restore a database from a dumpfile. When I run the command:

mysql -u root -p  BIO < /Volumes/Seagate/sql_bkp.sql

I get the error message:

-bash: mysql: command not found

I have tried running the restore command from my home directory and I get the error message. I also checked to find out where mySQL was installed and did a cd to that directory but I still get the same error. I believe this is some sort of PATH error but I'm not sure how to fix it. Any help would be appreciated.


#2

I was able to find a work around. I installed sequel pro and it was able to perform the database restore without any difficulty.


#3

This is a SQL Server forum, so you may not find folks here that are very familiar with MySQL. I believe there is a forum on the MySQL website, so that might get you better answers in future.