SQLTeam.com | Weblogs | Forums

SSRS Report not displaying data for one user


#1

Hi,

I have created a SSRS report. All the users can view the report except one. When this user generates the report, there are two fields which do not contain any data. I have tried removing the user from SSRS security and re-adding them but this has not solved the problem.

How can I fix this ?

Thanks


#2

where do the fields come from? Is it a particular SSRS dataset? do you run the report under the user's security context? If so, does the user in question have enough permissions on the database used in the SSRS dataset?


#3

The fields are coming from a SSRS dataaet I have setup the user with the same rights as the other users in SQL and SSRS. I am not sure how to run the report with the same security context as the user.


#4

Hi Samuels,

When using temporary tables, SSRS fails to get the metadata. So there are basically 2 ways of letting SSRS know the column names:

  1. Add SET FMTONLY ON. This will retrieve the metadata but it won't display the data.

  2. Go to the DATA tab and click on the Generic query designer and click refresh fields. This will prompt a dialogue box for specifying the parameter value. When we run the query in query designer SSRS gets the schema and the data from the stored procedure. Now the data will be available in preview pane.


#5

I am not using temporary tables in the report.

I have changed the authorization for the report to use stored credentials to see if this would solve the problem but it has not.