SQLTeam.com | Weblogs | Forums

"sqlservermanager15.msc" nowhere to be found

I am following an EF Core tutorial and apparently, I didn't have a database running (I'm in development environment, therefore localhost) and I didn't know how to configure SQL Server to do it. So I've done the following:

  • Downloaded and installed SQL Server Express (2019)
  • Downloaded and installed MSSM 18
  • I have mmc.exe and can open it

I'm following the SQL Server documentation, "Quickstart: Connect and query a SQL Server instance using SQL Server Management Studio (SSMS)".

When I try to connect to localhost with MSSM, it says "Cannot connect to localhost." The error message states:

For help, click: ***

The resulting page says:

Explanation
SQL Server did not respond to the client request because the server is probably not started.

User Action
Make sure that the server is started.

But I didn't know how to start the server. There is a link to a page:

Manage the Database Engine Services

It states:

SQL Server Configuration Manager is a Microsoft Management Console (MMC) snap-in.

It then says:

To access SQL Server Configuration Manager

On the Start menu, point to All Programs, point to Microsoft SQL Server, point to Configuration Tools, and then click SQL Server Configuration Manager.

But I don't have SQL Server Configuration Manager. So I googled:

If you are running Windows 8 and above, you might have found out that you can’t find SQL Server Configuration Manager in the list of installed applications. This is because SQL Server Configuration Manager is not a stand-alone program, and therefore doesn’t appear as an application in newer versions of Windows. The SQL Server Configuration Manager is a Microsoft Management Console snap-in.

You can find the SQL Server Configuration Manager snap-in in the C:\Windows\SysWow64 directory, as shown below.

However, I don't have any of these files. I cannot find a single instance of SQLServer*.msc on my computer. Therefore, no surprise that I'm not able to find SQL Server Configuration Manager to add as a snap-in when running mmc.exe.

I've also reinstalled SQL Server Express 2019, but without success. My destination folder is D:/SQL2019, I also can't find anything there. I also can't find anything relevant in the installation center. For example, the System Configuration Checker doesn't find any issues.

What else can I do? I'm working on Windows 10.

Thanks

Just restart your PC and try to connect with LOCALHOST\SQLEXPRESS

1 Like

Thank you, but it's not working (on MSSM). I guess that's because I first need to add the (currently non-existing) snap-in on mmc.exe, right? Error message:

Cannot connect to LOCALHOST\SQLEXPRESS.
...
A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified) (Microsoft SQL Server, Error: -1)

I also tried the dot, and when I tried to "Browse for more", there were no options available.

OK, I figured it out. I again uninstalled SQL Server 2019 together with what seemed to be some other tools from previous versions of SQL Server. This time I select the default installation process of SQL Express. With the custom installation, I can't recall the window popping up afterwards giving me all the connection information that I would need, with the "Connect now" button. Well this time it showed and it seemed to connect. This time I could also add the snap-in and then I could use the given server name, "localhost\SQLEXPRESS", to connect using SSMS.

1 Like