SQLTeam.com | Weblogs | Forums

SQL Server export wizard error on Oracle OLE DB provider


#1

I'm trying to export from SQLExpress 2012 to Oracle 11g using the export wizard in SQL Server Management Studio. When I try to configure the Oracle OLE DB provider and test it, I get the error "Test connection failed because of an error initializing provider".

If I test the OLE DB using the tip in this article, the test is successful.

I have a linked server configured from SQL Server to the Oracle database using OLE DB which does connect.

I mostly work with Oracle, so maybe there's a configuration issue here, or maybe I'm missing a piece somewhere linking SQL Server to Oracle OLE DB? Why would OLE DB work in one place but not in the export tool?


#2

UPDATE: it looks like the 64-bit export works; the 32-bit export tool fails. So is there somewhere I can tell SSMS which tool to call when I run Export or Import?


#3

I have experienced this issues as well. The whole Oracle OLEDB 32/64 bit library thing is a pain. Do a Google search on the error message and there are articles that can help. I worked with this using SSIS over four years ago and was able to find a solution back then that worked. Since it was so long ago I don't recall the specifics but I know it can be done and I was able to find the help online. It's a fairly common issue.