SQL Server 2014 Express Installation error


I am trying to install SQL Server 2014 Express (64-ADV) on a Windows 10 machine, but getting the following error -

"Attempted to perform an unauthorised operation". The failed components are Database Engine Services, Reporting Services - Native, SQL Server Replication and Full Text and Semantic Extractions for Search.

As this is the latest version of Windows 10 I assume I don't need any update/install for the .NET 3.5 or 4.0 environments. They aren't listed explicitly in Programs and Features but show up as partially enabled in Windows Services On/Off.

Do I need to install Visual Studio as a pre-requisite?

I have performed a system restore after the last failure to try to get a clean baseline to restart, and deleted folders etc from Program Files.

If anyone can help it would be much appreciated. Thanks.

Visual studio is not a prereq (or else it would be documented). Can you post exception details, screenshots etc?

Thanks. Log attached.SQPEXPR_2014 errors_0005SQPEXPR_2014 errors_0002SQPEXPR_2014 errors_0004SQPEXPR_2014 errors_0003

What account are you using when you run Setup.exe? does it have login as administrator privileges?

I only have 1 account set up and yes it does have admin privileges. I have also relocated install files to a newly-created folder but not success there. Frustrating as I have installed SQL Express on another machine a couple of years back with no problems.

You cannot install the RTM version of SQL Server 2014 Express - it requires at least SP1 for Windows 10. If you downloaded this: https://www.microsoft.com/en-us/download/details.aspx?id=46697 and are still having issues then I would recommend trying 2016 instead.

Hi. Tried using SP1 link but getting the same error. I have checked the event log and pulled out the message below which would have generated towards the start of the install. This is only a warning but may be linked -

A provider, SQLServerEventProvider, has been registered in the Windows Management Instrumentation namespace root\Microsoft\SqlServer\ServerEvents\SQLEXPRESSEOG3 to use the LocalSystem account. This account is privileged and the provider may cause a security violation if it does not correctly impersonate user requests.

Haven't stopped the installation yet as hoping to change the appropriate setting and retry from failure point. Fed up with uninstalling and retrying from scratch. Any suggestions welcome. Thanks.

It then errors with the following (from event viewer) -

initerrlog: Could not open error log file ''. Operating system error = 3(The system cannot find the path specified.).

What's the version of your Windows 10?

I have just had success but only by uninstalling antivirus software first..


aha! We could have told you that SQL Server is a virus!

1 Like