SQLTeam.com | Weblogs | Forums

SQL Repliaction trubble

#1

Hi,

I tried to add new article to already existing and working publication and replication. I create a new snapshot after that and creation went fine. Replication started and table was created on subscriber, but stay empty with following error massage:

Error messages:
The process could not bulk copy into table '"dbo"."Table1"'. (Source: MSSQL_REPL, Error number: MSSQL_REPL20037)
metadata query failed
Invalid character value for cast specification (Source: MSSQLServer, Error number: 22018)
Unspecified error

Publisher/Distributor: MS SQL 2008 R2 (SP3) - 10.50.6529.0 (X64)

Subcriber: MS SQL 2016 (SP2-CU3) (KB4458871) - 13.0.5216.0 (X64), Compatibility level 130, same collation as on Publisher

And everything else is working fine, transactions goes from one server to another server, except that table table 1 , which is empty. And I tried to create snapshpot few times, with same result.

Any suggestion?

0 Likes

#2

See if this helps

https://www.sqlservercentral.com/Forums/1809008/SQL-Server-Snapshot-Replication-error-22018

0 Likes

#3

I believe replication supports 3 major version difference. 2008 to 2014 works but not 2008 to 2016.

0 Likes

#4

Hi,
thanks for replay. Yes, so MS says, but this replication was working before this change and works after this change, except this particular table. Nothing else were changed, no service packs, no cumulative updates, except I added this table to publication. So, I start to dig in other direction, to see how data are clean.

0 Likes