SQLTeam.com | Weblogs | Forums

SQL 2014 instance - cannot uninstall


#1

I have an environment with 2 servers, each one is running Windows Server 2012, with a default instance of SQL Server 2014 and 4 additional named instances. The names instances on each server match up, and they each have dbs that are mirrored to the other server.
I need to uninstall several of the instances, so I have done this on the first server, but when I go to do it on the second server, nothing happens. I am going to Control Panel -> Programs -> Programs And Features, and then right clicking on the Microsoft SQL Server 2014 (64 bit) entry, selecting 'Uninstall/Change', and then choosing 'Remove' from the popup window. When I click Remove (or Add or Repair for that matter), nothing happens. I have tried uninstalling other programs, and it works fine, and, as I said, it worked fine on the other server. I have also discovered that I am not able to install a new instance either, which I can also do on the other server. We have the install files stored in a network location accessible to both servers, and is the install file that was used to install the instances in the first place, but now, one of the servers won't run it, but it isn't giving me an error either.
Please, does someone have any idea what has happened on this server?????


#2

Have you tried rebooting?


#3

Yes, several times so far. No change on any occasion.


#4

I think you're going to need to call Microsoft for help.


#5

How are these databases mirrored? Is this a Microsoft cluster or some other type of cluster - or are you using some type of SAN replication to mirror the systems?


#6

It is SQL Mirroring.

And although we don't know what we did to clear the problem, something has worked, as we are now able to uninstall and install SQL again on the second server.

We think it was related to language setups, as one setting had been altered somehow (we assume inadvertently). One of my colleagues found the error saying that the language wasn't supported in an obscure log file somewhere.

Many thanks
Chris