SQLTeam.com | Weblogs | Forums

One or More server network addresses lacks a fully qualified domain name (FQDN)


#1
  1. Trying to set up the mirroring with sql server 2008 instances. All are of same edition, enterprise.
  2. The mode I am trying to set up is automatic fail-over with high safety.
  3. I have searched the whole world with no solution.

Tried all steps, importantly - alter database ++++ set partner = ' '.

Looking for assistance from great minds.

Thanks
Sathya


#2

What is your problem? Does the MS instructions not answer one of your questions?


#3

What am I doing?

  1. Three instances, principal is windows server 2008 enterprise, mirrored datacenter 2008 and witness is windows 2008 server.
  2. Taken a backup (full and log) and restored with no recovery in mirrored.
  3. Then from principal setting up the mirroring, after configuring the security when I say start mirroring with high safety and automatic failover I get the above message.
  4. It appears that only for the principal server the network path and/or fqdn has taken as TCPIP://node1.abc.com:5022 for others (mirror and witness) it is only tcpip://node2:5022 and tcpip://node3:5022
  5. Now the only solution the MS appears to be providing is - alter database XXXXX set partner = 'TCP://node2.abc.com:5022'; but id just doesn't work.

#4

It's not an error. It's a warning. Typically, you always want to use a fully qualified domain name (FQDN) for the partner name. while, you are working in a workgroup instead of a domain, you don't have a fully qualified domain name.
Hopefully, you are in a domain and can simply use the FQDN. I see this warning when I set up mirroring on named instances on my personal laptop.However, if not, you can just continue. Mirroring set up will proceed if you ignore the warning.

https://msdn.microsoft.com/en-us/library/ms190941.aspx


#5

Thank you Jason for your response.

Agreed that it is only a response, but it is not allowing me to enable the mirroring option of "High safety with automatic failover" ie., the third listed option while setting up mirroring. I have no issues with the mirroring modes with which witness is not needed.

Thanks
Sathya


#6

Did you try dropping the mirroring endpoints and recreating them with the FQDN?


#7

Yes Tara, I did. Completely, one by one for all the three instances and then manually created/recreated them. But no respite. Basically I have three VM's, so all are independent machines in a way.

Thanks
Sathya


#8

As a last resort I have re-created the whole setup, ie., VM, Now I am stuck with a new error msg.


#9

Have you verified that each node can connect to each of the SQL instances?

Regarding the previous error, have you verified the DNS entries are correct? I remember having a mirroring or AG issue that was resolved by fixing the DNS entry.


#10

Hi,
Make sure your SQL services in all server principal, mirror, witness and using all same domain user.
You can use SQL Configuration Manager and go to SQL Server Services and see Log On As columns in all the server using the same domain user.