Not able to add db to Alwayson Group seccondary


we configured Always on configuration. Due to some reasons we removed 1.3 tb db from always on.

Now we wanted to add that db to again in Ag Group. But when i am adding the db in Ag, everything successful. But in secondary replica in Availability database i am able to see the db with yellow mark down. but in main database list i am not able to see .

While adding the db configuration i checked the backup in shared folder whether it saved or not. every thing is successful. But i am not able to see db in main db list with Syn message. i am not able to understand why db not syncing in secondary. Similarly this happens in DR secondary node.

we configured as Primary -Synchronous, secondary & DR Secondary as Asynchronous,Manual mode. The db is full recovery . all prerequisites meets while adding db in Ag.

Just for sample i created Test db in primary and tried adding in Ag group. Without any issue it added in both secondaries. Also the db is sync.

Why i am not able to add one perticular db which we deleted before?

Please help me.i am struggling to add the db. i googled. i found this below link which is similar to my issue, but when i tried executing the command i am getting syntax error at Grant.I am not able to understand y i am not able to add the db to secondary replicas.