Managed Instance - Storage Blob Container Backup file Upload issue


Can someone help out as having issue while uploading the file in Azure Storage Blob container?

I have backup taken of on-prem DB which is in Full recover model, DB size is around 900 MB but when I tried to upload the .bak file it's throwing following error, I also tried to split the files in Multiple files but still same issue:

Is it permission issue or any network issue?

I have owner role on storage account.

Failed to upload blob(s)

Failed to upload 1 out of 1 blob(s):

SqlDB.bak: error

I tried with using my on-prem sql server and it also having an issue when I tried to use Backup to url using SAS token.

I have created SAS token using READ/WRITE/LIST permission, there are no '?' in my token btu I tried to take a backup to store into Storage Blob container URL, it's also throwing an error:

"Operating system error 50 (The request IS NOT supported.)”

Note: I have set up expired after 1 year, there is no '?', Azure Storage services is Blob storage, storage account has all permission access like READ, WRITE, DELETE, LIST etc, SAS creation has the start time, expiry time, and permissions are specified in the SAS.

Appreciate your further help as I can't move further as I need to restore the database also.

Thanks for your help, appreciated it!