Lost remote connectivity

Up to about a week ago everything worked like a champ. My programs that access the DB had no issues grabbing data off the DB server.

The only change made to the network was I changed out the ROUTER last week (previous router failed) and made no changes whatsoever to the DB server. MSSMS version is v20.1 with no updates pending.

I can access the DB server from all computers on the network, fine and can open explorer and browse, read/write where ever I wish on the server (obviously that which is shared and accessible). However my connection to the SQL server and the databases is refused when attempting to access the DB.

I checked all settings and they have not been changed in any manner. Running MSSMS on the DB server gives me no issues and can access all DBs without issues.

I, however, am noticing in MSSMS that the 'Routing and Remote Access' service is NOT starting (although I do not recall that ever not starting prior to this issue arising). Manually starting the service makes no difference.

When connecting from any remote computer (using SSMS or my programs that need access to the databases) to the DB server the following error is given:

Cannot connect to PETS-SERVER\PETS_DATA
A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified) (Microsoft SQL Server, Error: -1)

For help, click: A network-related or instance-specific error occurred - SQL Server | Microsoft Learn

Checking the SQL SERVER Connection Properties results in the same error as shown above.

The MS link given, is liken to a elementary student trying to read and understand a doctorate journal with very little 'help' given to the layperson thus is utterly useless to me. However, I did spend multiple hours reviewing my settings, using more understandable help pages on the Internet, ensuring various items were in place (SQL browser started, etc.) and found I had no reason to change any settings already set and were performing perfectly fine previous to the router change.

Is there a specific router setting I may have missed and need to check to ensure the connection can go through? New router is an ASUS GT-AX11000 Pro. I am at a loss as to what happened.

This sounds as though you are trying to access SQL Server behind a router with TDS. This is generally not a good idea; it is usually better to RDP into the LAN or access SQL Server via some sort of Web Service. (eg RestAPI)

If you really want to access SQL Server behind a router you will need to configure port fowarding on the router. For the default instance of SQL Server this will usually be port 1433.