SQLTeam.com | Weblogs | Forums

Error message ssrs 2008 r2

I am getting the following error when I run the report in Visual Studio,
"The EXECUTE permission was denied on the object 'Dataset1', database 'OPSDataStore', schema 'dbo'. on On an SSRS 2008 R2 report,

Dataset1 is a dataset in the report and contains embedded sql. When I run the embedded sql on sql management studio, everything runs fine.

However when I run the report, I get the error I just listed above. The dba says that I am assigned as dbo owner on the test database. Thus this should not be a database error. The error has something to do with the ssrs report..

I am getting this error message on userid parameter value. I am using the following for the parameter value
= right(User!UserID,10)

Thus would you tell me what you suggest that I look at to see where the proiblem actually lies?

Sounds like you are not logged on with the userid, and therefore, permissions that you are thinking you are ... don't know how your embedded code is running, but maybe IT is running with different permissions for some reason.

1 Like