SQLTeam.com | Weblogs | Forums

Double clicking a word and exclude double quotes


#1

Does anyone know of a setting that will prevent SQL Server, version 2012, to NOT include opening and closing double quotes when I double click a word?

For example:
Select Cust as "Cust_Name"

When I double click anywhere inside "Cust_Name" to copy and paste, Cust_Name, WITH the opening and closing double quotes gets selected. All I want to get selected is Cust_Name WITHOUT the opening and closing double quote when I double click.

Not sure if this is a windows obscure setting or a setting in side SQL Server or not. Each application, MS WORD, etc. seems to have its own way of doing this.

TIA


#2

I think SSMS does this all wrong (also things like Control-Arrow to move a word - that seems to stop at all sorts of irrelevant break cahracters, which to my mind are not the simple "next-word" that other Program Editors seem to manage to do Just Fine), so I am still using the old Query Analyser from SQL 2000 or there abouts!


#3

I am going to bet this is not something you can control. It all depends on what SSMS considers a value to be selected when you double click.

I verified that the two SELECT statements below will grab the whole "word" including the brackets or double quotes while the third does not. I am using SSMS 2016 and 2014.

It all depends on the editor you use. I tried SSMS and then tried TextPad and Aqua Data Studio. SSMS is the only one that will behave that way.

I think you are out of luck but I would be happy to learn if that is a configurable setting that can be changed. As Kristen stated, the CTRL key behavior is also affected and that is annoying to deal with when working on different editors.

SELECT NULL As [TestMe];
SELECT NULL As "TestMe";
SELECT NULL As 'TestMe';

This was posted as a connect issue and closed as won't fix.See details here: Connect 363622

The "funny" thing is that if you are editing MDX files in SSMS, the behavior is as you would like to see. See those details here: SSMS and MDX