SQLTeam.com | Weblogs | Forums

Creating SQL Database on my desktop - can't connect


#1

Hi, I'm somewhat new to SQL and in trying to expand my knowledge, I am trying to install and create a database on my desktop. I am using SQL Server 2005 express desktop manager with Windows 8.1. It installed fine but I am stuck on the connect screen. Someone said to use ".", others ".\SQLExpress", and still others some combination of my PC name and SQLExpress. Nothing works as a server name!

I get connection errors every time. Seeing as I do not want to connect out, but create a brand new database, I don't know what's going wrong. Server type is "Database Engine" and I am connecting with Windows Authentication. The password is grayed out and I can't type anything there.

Could someone walk me through the desktop connection process? Thanks in advance!


#2

Hi,
I had similar problems too and tried a number of options. What you have done seems about right.
I have the following:

Server type: Database Engine
Server name: .\SQLEXPRESS
Authentication: Windows Authentication

This is for my work laptop, but for my home pc, im sure i set

Server name: . 
Authentication: SQL Server Authentication
Username: sa
Password: [blank]

Also check is "SQL Server(SQLEXPRESS)" was stopped. Enabled it by opening Control Panel > Administrative Tools > Services, right-clicking on the "SQL Server(SQLEXPRESS)" service and selecting "Start" from the available options. Then try both the above.


#3

Hi, thanks for the reply. I don't actually see SQL Server in administration tools. That may be my problem, but I am not sure how to remedy it. SQL seemed to install fine once I got to an administrator command prompt. Do you think it has to do with .net or XML not being installed right?


#4

Not in Administrative Tools. in Administration Tools/Services


#5

Yes I am in services, and looked in both the Extended and Standard tabs. There's nothing that says SQL there. Can I add it somehow?


#6

Sounds like your installation didn't complete properly or you need to reboot