SQLTeam.com | Weblogs | Forums

Can't see the Disable Trigger option in SSMS

Is there any reason that the "Disable" option won't display on Trigger ?
Is is due to the Server version ?
The server is Microsoft SQL Server Express (64-bit)
Version 15.0.2080.9

Thanks for any help

Does your login have the sysadmin role?

Thank you DBAforever
Good Question :slight_smile:
I've just had a quick look in the server properties / permission but I don't know where to find the SysAdmin role ...
BTW : On another SQL Server connection I don't find Sysadmin neither however I can disable / enable trigger

Ouf ! : I've found it
And yes I have the Sysadmin role ...

And this is what I see in SSMS

image

What version of SSMS are you using?

Thank you Jeff

Mentionned in the fist post :slight_smile:

The server is Microsoft SQL Server Express (64-bit)
Version 15.0.2080.9

Thanks for any help

Okay - but I asked about the version of SSMS. Not the version of SQL Server.


And it is working fine on another Server

Okay - that is the latest version of SSMS. Just to confirm - when you connect to another instance of SQL using that version of SSMS you can see the enable/disable options on triggers?

What is the difference in versions of SQL Server? Is the other version also Express Edition - is there a difference in editions or versions?

BTW - there have been quite a few updates for SQL Server 2019. The latest CU is CU11 with build 15.0.4138.2. I would try upgrading SQL Server to that release and see if that fixes the problem.