SQLTeam.com | Weblogs | Forums

Can't Restore Database - Damaged?


#1

I'm not able to restore a Database from 2005 onto 2008. It may be damaged but it's very large and from another country - it took 5 days to copy the file here. Here are the details of what I ran into - if anyone has any ideas, please let me know...

I tried the restore - error:
RESTORE detected an error on page (0:0) in database "..." as read from the backup set.

Then I tried RESTORE VERIFYONLY:
Attempting to restore this backup may encounter storage space problems. Subsequent messages will provide details.
The path specified by "I:....MDF" is not in a valid directory.
Directory lookup for the file "L:....LDF" failed with the operating system error 2(failed to retrieve text for this error. Reason: 15105).
Msg 3189, Level 16, State 1, Line 1
Damage to the backup set was detected.
Msg 3013, Level 16, State 1, Line 1
VERIFY DATABASE is terminating abnormally.

So I tried a restore with CONTINUE_AFTER_ERROR. Error:
Converting database '...' from version 611 to the current version 661.
Database '...' running the upgrade step from version 611 to version 621.
Msg 601, Level 12, State 3, Line 1
Could not continue scan with NOLOCK due to data movement.
Damage to the backup set was detected.
RESTORE WITH CONTINUE_AFTER_ERROR was successful but some damage was encountered. Inconsistencies in the database are possible.

And currently when I try any statement on the Database I get:
Cannot open database '...' version 611. Upgrade the database to the latest version.


#2

I would run DBCC CHECKDB on the source database to see if there's any corruption. If that checks out, then I would say the backup is damaged. You may want to put it onto a device and have the device shipped rather than file copying it.


#3

There can be several reasons for occurring above errors, take a look on this article, It might be helpful for you.


#4

This portion of the error message implies that the drives and/or directories on the source and destination servers are not the same. If it is a case of the directories not existing, you can create them at the target. For drives, you'll need to invoke the MOVE option of the RESTORE DATABASE command to map to the new location(s). I suspect that you'll still run into the "Damage to the backup set was detected." error though. Alas...


#5

Expecting a 5 day stream of data to operate flawlessly is likely an unreasonable expectation even in the world we live in today. The best thing to do would be to have then mail you a compatible tape or even a relatively inexpensive IDE drive with the data on it. Even if it takes more than 1 drive, it should take less than 5 days to "try again".


#6

The error 15105 shows that, user is trying to create a database backup (.bkp) file with the network shared disk or hosting the database file on a network share which is unable to support, then such error message takes place.
Know more about the error on http://sqltechtips.blogspot.in/2015/12/backup-error-15105.html