SQLTeam.com | Weblogs | Forums

Can't create BACPAC from SSDT. What am I missing?


#1

I have a database for ERP software I support.
My client want to move the DB to Azure, so I have tried to generate a BACPAC file from SSMS which generated heaps of errors - various errors ranging from missing clustered indexes, fillfactor not supported, to windows authentication users issues and a few other errors.
Googling various articles directed me to download SQL Server Data Tools which gave me a good interface to fix up the errors.

So now I have a saved project in SSDT & I can run the 'build' without any errors, so it should be able to export schema & data to a BACPAC file successfully.
However within SSDT when I right-click the database, Extract Data-Tier Application, although it gives me the option to export schema & data, it is only wanting to create a DACPAC file. How can I create a BACPAC file, using the build or DACPAC file the build has created?

If I use Management Studio to generate the BACPAC file, I get all the errors again because it has no knowledge of the DACPAC file I've worked on in SSDT.

If I use the command-line SQLpackage.exe to create the BACPAC, I get further errors, as if I was just using SSMS.

Surely there must be a way to export schema & data from SSDT into a BACPAC file? I have spent quite literally days on this, googling & reading various articles but I just can't find the answer to this predicament.

Cheers

Danster


#2

Have you read SQL Server database migration to SQL Database in the cloud