SQLTeam.com | Weblogs | Forums

Can't connect to SQL Server from only one workstation

Weird. There are 6 workstations and all but 1 can connect to SQL Server using the exact same connection string. So the SQL engine is obviously running and the issue is not centralized at server level (e.g. "Allow network connections to this server", "Maximum number of concurrent connections", "Named pipes"). Checked the firewall on the station and it's OFF at all levels. Even tried to add incoming and outgoing firewall rules for TCP 1433 and UDP 1434 with no effect. I tried to connect using the IP address of the server instead of its name in case there might be a name resolution issue between stations, but nope.

What else should I be checking on that workstation?

Thanks!!!

Suggest looking in the SQL Server error log for login failures, if you're configured to log those. You can also query the default trace for login failures.

Here's a starter for querying the default trace:

Actually, the problem doesn't seem to be at login level. Fact is, the workstation simply doesn't see the SQL server instance at all across the network. For instance, if I create a UDL file and configure it to use the Microsoft OLE DB Provider for SQL Server, and then ask it to scan for all the SQL Server instances that it sees over the network, it cannot see the instance. Something is blocking the workstation from seeing the SQL Server instance which is on the server computer. Normally, that would be the firewall but it's disabled !

Sounds more like networking and domain or workgroup issue. From your past posts sounds like maybe you have a workgroup setup? Is this work station part of it? Or part of same domain as sql? Is it new in the bucket of workstations?

Actually, I have hundred of clients so the situation always varies from one case to another. But in this case, upon verification, it appears that the client installed a new server as domain controller, moved all his workstations to the newly created domain but left the SQL server behind on a workgroup. Instinctively, I would say that you've nailed it and that's the issue. But, again, all workstations are finding the SQL Server and connecting to it without issue except for one, which is the part which is eluding me. I can't put my finger on what is making one workstation behave differently from the others.

Again I highly doubt it is a sql issue. Check ip of problematic workstation,
Gateway , subnet, vlan etc