SQLTeam.com | Weblogs | Forums

Cannot install Polybase on existing cluster node

Hello all...

I have a existing 2-node cluster, running SQL Server 2019 with CU8 (latest), and I am trying to install the Polybase feature; which is supposedly supported. (The support is implied in this support link; where the person has a problem installing it as well: https://support.microsoft.com/en-us/topic/kb3173087-fix-polybase-feature-doesn-t-install-when-you-add-a-node-to-a-sql-server-2016-failover-cluster-39d0ab14-5a29-627a-7a75-1b8805a661c0)

First hiccup, which was resolved, is that to install Polybase on an existing instance, then you need ensure "Shared Memory" protocol is enabled. Just having TCP/IP and/or named pipes doesn't work.

Second hiccup: "The instance selected for installation is already installed..."

Well, I know the instance already exists. After all, I selected the instance name 3 screens ago.

So, I tried to cheat using this command:
Setup.exe /SkipRules=StandaloneInstall_HasClusteredOrPreparedInstanceCheck /Action=Install

I got a bit exciting thinking that I had solved the issue. I got to the final screen (that shows you it is ready to install), but I then this:
image

(In case anyone wants to ask, the link in the error message doesn't work. Not a huge surprise there either.)

So now I'm stuck. Any suggestions, anyone?

Thanks!