SQLTeam.com | Weblogs | Forums

Backup Database not backing up selected database

I have tried everything I know and still unsuccessful.

I attempted to copy a database from one server to another - ultimate fail on last step and there is NO log file showing me what the error is.

So I tried exporting the database (to import onto the new server and it is consistently exporting the incorrect database. Again, ultimate fail.

So I attempted to backup dbo.AmateurRadio database.

In MSSMS I follow the following steps:

  1. Connect to the server
  2. Expand the Databases (to see the different DBs)
  3. Pick the AmateurRadio database and right click on it and then choose Tasks/Back-Up (wizard opens)
  4. Database Name AmateurRadio
  5. Recovery model and Back-up Type is FULL
  6. Back up to Disk
  7. Location and name set to backup is set - CLICK OK
  8. Receive successful message that AmateurRadio is backed up.

When I attempt to restore the backup (onto the new server into dbo.AmateurRadio) - it tells me 'the backup set holds a backup other than the existing AmateurRadio database'

Why/How would/could that be... what am I missing when it comes to backing up the AmateurRadio Database?

OK, Disregard the above - Massive Brainfart....

Doing a simple restore from a back-up by simply restoring a 'new' database works - NOT into an already existing database that is blank ....

PROBLEM RESOLVED... Complete meltdown of the brain... I KNEW this!!! LOL

2 Likes