Back up failed

Hi everyone.
i Have a backup job for all Production dbs. and it is been failing since yesterday. i tried different approaches but could't find the issue.
the message says ::Executed as user: ECSLIMITED\sqlservice. sqlmaint.exe failed. [SQLSTATE 42000] (Error 22029). The step failed.

What is the destination backup folder and could it full

thank you for replying. the destination back up is on D and i checked it has space (370544MB)

Has it ever worked?

For the maintenance plan, you can view history. That will often tell you the error.

yes, it has been working for a while until a day ago. i can't really find any relevant hints in history.

If this is a maintenance plan - you need to view the history of the maintenance plan and not the history of the agent job. In Object Explorer - navigate to the maintenance plans and right-click on the plan to view the history.

Identify the step that failed and look at the message associated with that failure. If you have further questions on what that failure indicates - you can post the failure message here.