SQLTeam.com | Weblogs | Forums

Added New Subscriber but Replication Not working

Hello Team,

I have 1 Merge Replication setup with 1 Publisher and 5-6 Subscriber.We have added 1 more new subscriber in this replication and when try to sync its giving below error.
Error messages:
The merge process was unable to deliver the snapshot to the Subscriber. If using Web synchronization, the merge process may have been unable to create or write to the message file. When troubleshooting, restart the synchronization with verbose history logging and specify an output file to which to write. (Source: MSSQL_REPL, Error number: MSSQL_REPL-2147201001)

The CREATE UNIQUE INDEX statement terminated because a duplicate key was found for the object name 'dbo.MSmerge_genhistory_75711cc468114cd2ad98d5573a252083' and the index name 'c2MSmerge_genhistory_75711cc468114cd2ad98d5573a252083'. The duplicate key value is (1334936). (Source: MSSQLServer, Error number: 1505)

I tried below things but did not worked.

  1. Created New Snapshot but not worked.
  2. changed agent profile with verbose history/big query timeout but still not worked.
  3. I found 1 duplicate entry in dbo.MSmerge_genhistory table with generation=1334936.I remove 1 entry and try to sync but not worked then I removed both entry and kept it on backup table and try to sync but again same error.

Kindly suggest what to do.

Thank you